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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates the procedure has
only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown (e.g., “copy
file1 ” means type the word copy, then type a space, then type file1).

o On-screen prompts and messages, names of options and text fields, and menu
commands. Menu commands are often separated by greater than signs (>) (e.g.,
“click HFSS > Excitations > Assign >Wave Port.”
).

o Labeled keys from the computer keyboard (e.g., “Press Enter ” means to press the
key labeled Enter).

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics (e.g., “copyfile name” means type the word copy, then type a space, then
type the name of the file).

l The plus sign (+) is used between keyboard keys to indicate that both keys should be
pressed at the same time (e.g., “Press Shift +F1 ” means to press Shift and, while holding
it down, press F1). Always depress the modifier key or keys first (e.g., Shift, Ctrl, Alt, or
Ctrl +Shift), continue to hold it/them down, then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Layout > Interface Ground "

This instruction means click Interface Ground from the Layout tab. An image of the com-
mand icon, or a partial view of the ribbon, is often included with the instruction.
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l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"From the Filemenu, selectOpen Examples" means click the Filemenu and select
Open Examples from the drop-down menu.

l Another alternative is to right-click and select from the shortcut menu. An example of a typ-
ical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means select an object, right-
click, and click an option from the shortcut menu that appears.

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. This information can also be obtained by contacting an Ansys
account manager.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps are taken
or what stages the simulation reached, including software files as applicable. This allows more
rapid and effective debugging.

Help Menu

From the Help menu, select Help and choose from the following:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

From the user interface, press F1 to open the help specific to the active product (design type).

Press F1 while the cursor is pointing at a menu command or while a particular window tab is
open. In this case, the help page associated with the command or open window is displayed
automatically.
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1 - Introduction
Complete theGetting Started with HFSS 3D Layout: Slot Fed Patch Antenna guide to cre-
ate and define a multilayer structure (consisting of three copper and two dielectric layers), define
its ports, then set up and analyze the design as a planar EM solution with a frequency sweep.
The model pass filter model consists of three copper and two dielectric layers). The user will
need to define the layers, draw the model, define the ports, and set up the solution. After solving
the model, the user will create a return loss report and add a marker from the trace, view surface
currents, and the radiation pattern (2D gain plot and 3D gain pattern).

The following figure is an illustration of a typical model representing a slot coupled patch
antenna.

The equivalent HFSS 3D layout of the model consists of the layers shown in the following cross-
section:

And finally, the following is a view of the HFSS 3D Layout model build:

Getting Started with HFSS 3D Layout: Slot Fed Patch Antenna
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Set General Options
Before creating the bandstop filter, follow these steps to ensure the default unit of length meas-
urement is set to cm.

Note:

Define general settings before adding an HFSS 3D Layout Design element to a pro-
ject. The general options control the default settings when the design type is added. To
change default settings after a design has been added to the project, from the Layout
tab, select Layout Settings.

Create the Layout 1-2
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1. Open theOptions window by doing one of the following:

l From the Desktop ribbon, clickGeneral Options.

l From Tools, selectOptions > General Options.

Create the Layout 1-3
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2. If appropriate, expand theGeneral group.

3. Select Default Units.

Create the Layout 1-4
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4. Select cm from the Length drop-down menu.

Create the Layout 1-5
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5. ClickOK to close theOptions window.

Enabling Legacy View Orientation
The instructions and examples in this guide use the legacy view orientation scheme, rather than
the controls introduced in release 2024 R1. Complete these steps to enable the Legacy View
Orientation and avoid any confusion.

Create the Layout 1-6
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1. Navigate to Tools >Options > General Options to open the 3D UI Options window.

2. ExpandGeneral and select User Interface.
3. Check the Enable Legacy View Orientation box. When the user has completed theGet-

ting Started Guide, they should return toOptions window and uncheck the Enable
Legacy View Orientation box.
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4. ClickOK.

Continue to Insert Layers.

Inserting Layers
Complete these steps to insert layers in an HFSS 3D Layout design.

Create the Layout 1-8
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1. From the Layout tab, click the Layers dialog button to open the Edit Layers window.

Create the Layout 1-9
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Note:

Alternatively, from Layout, select Layers.

2. In the Edit Layers window > Stackup area, selectOverlappingfrom the Type drop-down
menu.

Create the Layout 1-10
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3. Click Layer and select either Insert above or Insert below to open the Add Stackup
Layer window.

4. In the Add Stackup Layer window, do the following:

a. Enter Feed in the Name field.
b. Ensure signal is selected from the Type drop-down menu.
c. ClickOK to close the Add Stackup Layer window add the new layer to the table in

the Edit Layers window.

Note:

The material copper is automatically assigned to signal layers.

Create the Layout 1-11
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5. Check the Rough box in the Analysis area.

Note:

The Rough attribute indicates the surface roughness of the conductors is taken
into account when approximating the impedance of the signal traces.

6. Right-click the Feed row and select Insert above to open a new Add Stackup Layer win-
dow.

7. In the Add Stackup Layer window, do the following:
a. Enter Sub2 in the Name field.
b. Select dielectric from the Type drop-down menu.
c. Enter 0.16cm in the Thickness field.

Create the Layout 1-12
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d. ClickOK to close the Add Stackup Layer window add the new layer to the Grid
Control Table.

8. Select Edit from theMaterial drop-down menu to open the Select Definition window.

9. From the Select Definition window, select Rogers RT/duroid 5880 (tm) from the list of
library materials. Then clickOK to close the Select Definition window.
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10. Right-click the Sub2 row and select Insert above to open a new Add Stackup Layer win-
dow.
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11. In the Add Stackup Layer window, do the following:
a. Enter Slot in the Name field.
b. Select signal from the Type drop-down menu.
c. ClickOK to close the Add Stackup Layer window add the new signal layer to the

table.
12. Check the Negative box in the Attributes area.
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Note:

The Negative attribute indicates the conductor is present everywhere except
where an object is drawn. The layer is an infinite ground layer, and the conductor
is removed in the area of a drawn shape.

13. Ensure the Rough box in the Analysis area is not checked.

Note:

The Rough attribute indicates the surface roughness of the conductors is taken
into account when approximating the impedance of the signal traces, but surface
roughness is ignored for ground layers. Deactivating the Rough attribute pre-
vents a warning to that effect from appearing during model validation and solu-
tion setup.

14. Right-click the Slot row and select Insert above to open a new Add Stackup Layer win-
dow.
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15. In the Add Stackup Layer window, do the following:
a. Enter Sub1 in the Name field.
b. Select dielectric from the Type drop-down menu.
c. Enter 0.16cm in the Thickness field.
d. Select Rogers RT/duroid 5880 (tm) from theMaterial drop-down menu.
e. ClickOK to close the Add Stackup Layer window add the new dielectric layer to

the table.
16. Right-click the Sub1 row and select Insert above to open a new Add Stackup Layer win-

dow.
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17. In the Add Stackup Layer window, do the following:
a. Enter Patch in the Name field.
b. Select signal from the Type drop-down menu.
c. ClickOK to close the Add Stackup Layer window add the new dielectric layer to

the table.
18. Check the Rough box in the Analysis area.
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19. From the Layer area, choose Select all from the drop-down menu.

20. Ensure the "shading" box in the Attributes area (i.e., the middle box) is checked. This
ensures that all objects will be shaded, rather than only outlined (wire frame).
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21. The Edit Layers window should now match the following example.

22. Click Apply and Close.

Continue to Draw Feed Line.

Drawing a Feed Line
Complete these steps to set the chosen working layer and draw the first object (i.e., a feed line).

Create the Layout 1-20
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1. From the Layout tab, select Feed from the Active Layer drop-down menu.

Note:

Alternatively, select Feed in the Layers window.

Create the Layout 1-21
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2. From the Layout tab, click Draw line.

3. Do not click+drag in the Layout Editor. Instead, move the cursor to the X coordinate field
at the bottom of the Layout Editor. Type -5 in the field.

4.  Press Tab to move the cursor to the Y coordinate field. Then type 0 in the field and press
Enter.

5. Press Tab until the cursor moves to the Delta X coordinate field. Type 7 in the field.

6. Press Tab to move the cursor to the Delta Y coordinate field. Then type 0 in the field and
press Enter to complete the ground plane.

7. Press Enter again to finish the line.

8. Select the new object to populate the Properties window. Then make the following
changes:

a. Enter 0.495 in the LineWidth row Value field.
b. Select cm from the Unit drop-down menu in the LineWidth row.
c. Ensure Flat is selected from the StartCapType drop-down menu.

Create the Layout 1-22

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Slot Fed Patch Antenna

Continue to Add Excitation (Port).

Adding an Excitation (Port)
Complete these steps to create an edge port.
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1. Right-click in the Layout Editor and choose Select Edges.

The cursor appearance changes to indicate it is in edge-selection mode.
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2. Click the left edge of the model to select it.

3. From the Layout ribbon tab, click Create edge port.

The port is added to the drawing in the Layout Editor (default name, Portn) and in the Pro-
ject Manager window (i.e., from the Project Manager window, expand the Project Tree
> [active design folder] > Excitations). Do not deselect the port.
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4. From the Properties window, select the EM Design tab.

Note:

There are PlanarEM-, HFSS-, and HFSS-PI-specific port properties. For an EM
Design, run either a Planar EM simulation or an HFSS simulation. Specific prop-
erties can be assigned to the port depending on the solver used (i.e., selectGap,
Wave, or Circuit port for an HFSS simulation.)

Continue to Draw Slot.

Creating a Draw Slot
Complete these steps to create the second object (i.e., a draw slot).

Create the Layout 1-26
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1. From the Layout tab, select Slot from the Active Layer drop-down menu.

2. From the Layout tab, click Draw line.

3. Press Tab to move the cursor to the X coordinate field at the bottom of the Layout Editor.
Enter 0 in the field.

4.  Press Tab to move the cursor to the Y coordinate field. Then type -0.7 in the field and
press Enter.

5. Either press Tab until the cursor moves to the Delta X coordinate field or move the cursor
to the field, click inside it, and enter 0.

6. Press Tab to move the cursor to the Delta Y coordinate field, Then type 1.4 in the field and

Create the Layout 1-27
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press Enter to complete the ground plane.

7. Press Enter again to finish the line.

8. Select the new object to populate the Properties window. Then make the following
changes:

a. Enter 0.155 in the LineWidth row Value field.
b. Select cm from the Unit drop-down menu in the LineWidth row.
c. Ensure Flat is selected from the StartCapType drop-down menu.

Create the Layout 1-28
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Continue to Draw Patch.

Creating a Draw Patch
Complete these steps to create the third object (i.e., a draw patch).

1. From the Layout tab, select Patch from the Active Layer drop-down menu.

2. From the Layout tab, click Draw rectangle.

3. Press Tab to move the cursor to the X coordinate field at the bottom of the Layout Editor.
Enter -2.0 in the field.

4.  Press Tab to move the cursor to the Y coordinate field. Then type -1.5 in the field and
press Enter.
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5. Either press Tab until the cursor moves to the Delta X coordinate field or move the cursor
to the field, click inside it, and enter 4.0.

6. Press Tab to move the cursor to the Delta Y coordinate field, Then type 3.0 in the field and
press Enter to complete the ground plane.

7. Press Enter again to finish the line.

Continue to Set Up Solution and Analyze.
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2 - Set Up Solution and Analyze
This chapter contains the following topics:

l Set Up a Planar EM Analysis
l Create Return Loss Report
l Add and Analyze a Discrete Sweep
l View Surface Currents
l Create Radiation Pattern
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Setting Up and Solving a Planar EM Analysis
Complete these steps to add a Planar EM analysis to the project, then validate and solve it.

1. Open the PlanarEMSetup window by doing one of the following:
l From the Simulation ribbon tab, click PlanarEM (i.e., Add Planar EM Solution
Setup).

l Right-click Analysis in the Project Manager window and click Add Planar EM
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Solution Setup.

Setting Up and Solving a Planar EM Analysis 3-2
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l From HFSS 3D Layout, select Solution Setup > Add Planar EM Solution Setup.

2. From the PlanarEMSetup window > Mesh Selection area, do the following:
l Ensure Fixed Mesh is selected.
l Enter 2.5 in the Solution Frequency field.

Setting Up and Solving a Planar EM Analysis 3-3
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l Check the Use edge mesh box.
l Select Absolute edge length and enter 0.1cm in the field.

3. ClickOK to close the PlanarEM Setup window and open the Edit Frequency Sweep win-
dow.

Setting Up and Solving a Planar EM Analysis 3-4
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4. Ensure Interpolating is selected from the Sweep Type drop-down menu.
5. Select Linear Count from the Distribution drop-down menu in the first row of the Fre-

quency Sweeps table.
6. Enter the following parameters in the first row of the Frequency Sweeps table:

l Enter 1 (GHz) in the Start column.

l Enter 3.5 (GHz) in the Stop column.

l Enter 201 in the Points field.

Setting Up and Solving a Planar EM Analysis 3-5
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7. ClickOK to finalize the interpolating sweep and close the Edit Frequency Sweep win-
dow.

8. From the Simulation ribbon tab, click Validate to open the Validation Check window.
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9. When the validation check is complete, click Close.

10. To run the Planar EM analysis, do one of the following:

l From the Simulation tab, clickAnalyze.

l From HFSS 3D Layout, select Analyze.
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l From the Project Manager window, expand the Project Tree > [active design
folder]. Then right-click Analysis and select Analyze.
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Note:

Alternatively, run a single sweep by expanding the Project Tree > [active design
folder] > Analysis folder in the Project Manager window. Then right-click the chosen
sweep and select Analyze.

View Progress
From the Electronics Desktop status bar, select Show Progress to expand the Progress win-
dow.
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During analysis, perform the following actions, as appropriate:

l Right-click within the Progress window and select Abort, Clean Stop, or Pause. Clean
Stop completes the computation of the current frequency point, then analysis ends.

l Right-click within the Progress window and select Change Priority > (Highest, Above
Normal, Normal, Below Normal, or Lowest Priority), to change the priority of the asso-
ciated solution. Altering the priority can be useful when multitasking, to free up resources
from a computationally intensive application. Conversely, it can prevent less important pro-
grams from excessively slowing down the more intensive application.

Continue to Create Return Loss Report.

Creating a Return Loss Report
Complete these steps to create a return loss report.
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1. From the Project Manager window, expand the Project Tree > [active design folder]
> Analysis > [chosen setup (e.g., PlanarEMSetup1)]. Then right-click the chosen
sweep (e.g., Sweep1) and select Results > Plot Templates > Return Loss to open a
Report2D window with an S Parameter plot (e.g., dB[S(Port1,Port1)]).

2. Click anywhere from the trace (i.e., the red line) to select it. The line becomes thicker when
selected.

Setting Up and Solving a Planar EM Analysis 3-12

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Slot Fed Patch Antenna

3. While the trace is selected, right-click anywhere within the Report2D window. Then select
Marker > Add Minimum. An arrow will appear, indicating the lowest position from the
line, along with a legend giving the marker's exact X,Y coordinates.
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4. Drag the legends to suitable locations and click anywhere outside of the trace to deselect
it.
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Continue to Add and Analyze a Discrete Sweep.
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Adding and Analyzing a Discrete Sweep
Complete these steps to add a new discrete frequency sweep, targeting the frequency at which
the minimum return loss occurred, and save the fields so a current overlay can be created and
animated after the sweep is analyzed.

1. From the Project Manager window, select the chosen analysis (e.g., PlanarEMSetup1).

2. From the Simulation ribbon tab, click Sweep to open the Edit Frequency Sweep win-
dow.

3. From the Edit Frequency Sweep window, do the following:
a. Select Discrete from the Sweep Type drop-down menu.
b. From the Frequency Sweeps area, select Single Point from the Distribution

drop-down menu.
c. Enter 2.3 in the Start field.
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d. Check theGenerate surface current box.
e. ClickOK to close the Edit Frequency Sweep window.

4. From the Project Manager window, right-click the chosen sweep (e.g., Sweep2) and
select Analyze.
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5. FromWindow, select Layout Editor.

Continue to View Surface Currents.

Viewing Surface Currents
After the discrete sweep analysis, complete these steps to add and view a current density over-
lay.
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1. In the Project Manager window, expand the Project Tree and [active design folder].
Then right-click Field Overlays and select Plot PEM Fields >Mag_SurfaceJ to open the
Create Field Plot window.

2. Under the Nets and Layers tab, click the blank column heading above the layer names to
simultaneously select all three conducting layers (e.g., Patch, Slot, and Feed layers.
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3. Click Done to generate the surface current density overlay.

4. Within the Layout Editor, double-click the J Surf plot legend to open the legend settings
window.
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5. Click the Scale tab.

6. Within the Number Format area, make the following changes:
a. Select Decimal from the Type drop-down menu.
b. Enter 8 in theWidth field.
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7. Click Apply.
8. Click Close. The changes will be immediately noticeable within the Layout Editor.
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9. Rotate the model to see all three layers, as shown in the following figure.

10. From the Project Manager window, expand the Project Tree > [active design folder]
> Field Overlays > J Surf. Then right-clickMag_SurfaceJ1 and select Animate to open
the Create Animation Setup window.
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11. Within the Create Animation Setup window, it should not be appropriate to change the
default settings, which follow:

a. The left and right drop-down menus are set to Single variable and Phase, respect-
ively.

b. 0deg is typed in the Start field.
c. 170deg is typed in the Stop field.
d. 17 is typed in the Steps field.
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12. ClickOK to close the Create Animation Setup window. The Animation controls window
will open and the animation will start.
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13. Use the controls in the Animation controls window to Rewind, Reverse, Stop,
Skip Forward, or Fast Forward.
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14. To end the animation, click Close.

Continue to Create Radiation Pattern.

Creating a Radiation Pattern
Complete these steps to create a 3D gain pattern, a 2D polar gain plot, and then review the res-
ults. Use predefined templates to generate these plots.

1. From the Project Manager window,right-click Sweep2 and select Results > Plot Tem-
plates > 3D Input Gain.
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The 3D gain input pattern report appears (e.g., Report3D).
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Note:

A default radiation setup is automatically defined (Infinite Sphere - Default Setup)
(e.g., Project Manager window > Radiation). This radiation setup is the basis of
the 3D Gain Pattern. Theta values range from 0 to 180 degrees (in 2 degree incre-
ments), and Phi values range from -180 to 180 degrees (also in 2 degree incre-
ments).
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2. Rotate the model to see the visualization from different angles.

Note:

In the following example, a Theta range of -180 to 180 degrees is desirable. Limit
Phi to two values (0 degrees and 90 degrees), resulting in only two traces.
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3. From the Project Manager window, expand the Project Tree and [active design
folder]. Then right-click Radiation and select Insert Far Field Setup > Infinite Sphere
to open the Infinite Sphere Setup window.

4. From the Infinite Sphere Setup window, make the following changes:
a. From the Phi area:

l Enter 0 in the Start field.
l Enter 90 in the Stop field.
l Enter 90 in the Step Size field.

b. From the Theta area:

l Enter -180 in the Start field.
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5. ClickOK to close the Infinite Sphere Setup window.
6. From the Project Manager window, right-click Sweep2 and select Results > Plot Tem-

plates > Radiation Pattern.
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The new radiation pattern report appears (e.g., Report2D1).

Setting Up and Solving a Planar EM Analysis 3-36

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS 3D Layout: Slot Fed Patch Antenna

7. Double-click the Theta axis (i.e., the outer circumference of the plot) to open the Prop-
erties window.
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8. From the Axis tab, do the following:

a. Remove the check from the box in the Auto Scale field.

b. Enter -30 in theMin Scale field.

c. Enter 10 in theMax Scale field.

d. Enter 5 in the Spacing field.
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9. Click Apply. Then clickOK to close the window.

10. If your plot matches the preceding figure, or simply contains more than two traces and cov-
ers the range of Theta = 0 through 180 degrees, the plot is most likely based from the
default infinite sphere setup. To correct for this, do the following:

a. From the Project Manager window, right-click dB(GainInput) (i.e., Report 2D1
> dB(GainInput)) and selectModify Report to open the Report window.
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b. From theGeometry drop-down menu, select Infinite Sphere 1.
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c. Click Apply Trace to simultaneously apply the adjustment to the current report.

d. Click Close.

Congratulations, the HFSS 3D Layout slot fed patch antenna getting started guide is
complete.
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